最新消息:

Deepin/ Ubuntu中 ./configure 的一些常见错误

Linux 450浏览 0评论

deepin.jpg

说明:

sudo apt-get install  package-name    #更新你指定的软件包 
sudo apt-get update                   #获取更新列表
sudo apt-get dist-upgrade             #开始更新

 ./configure的问题 

错误:C compiler cannot create executables 

原因: 

解决:

sudo apt-get gcc libc6-dev

错误:checking for C compiler default output… configure: error: C compiler cannot create executables 

原因: 

解决:

sudo apt-get install libc6-dev

错误:configure: error: C++ preprocessor "/lib/cpp" fails sanity check 

原因:gcc的组件没装全 

解决:

apt-get install build-essential

错误: Can't find X includes. Please check your installation and add the correct paths! 

原因:没有X的包含文件 

解决:安装xlibs-dev即可 

错误: Qt (>= Qt 3.0) (headers and libraries) not found. Please check your installation! 

原因:查找提供qt的lib&&headers的软件包,并安装之 

解决:

apt-get install libqt3-headers libqt3-mt-dev

错误:in the prefix, you've chosen, are no KDE headers installed. This will fail. 

So, check this please and use another prefix! 

原因:install a KDE application in a Gnome environment。 

解决:which basically means its going to want to install a lot of KDE specific packages to work. 

This 'configure:error'
is due to it expecting you to be running KDE and again refers to some 'headers'. 

sudo apt-get update
sudo apt-get install kdelibs4-dev kdelibs4c2a

错误:./admin/cvs.sh: 585: autoconf: not found 

原因: 

解决:

apt-get install autoconf

错误: *** GTK >= 2.4.0 not installed! *** 

原因:没装GTK 

解决:

apt-get build-dep gedit

错误:heching for gtk-config… no
checking for GTK – version = 1.2.0… no 

*** The gtk-config script installed by GTK could not be found 

*** If GTK was installed in PREFIX, make sure PREFIX/bin is in 

*** your path, or set the GTK_CONFIG enviroment variable to the 

*** full path to gtk-config.
configure: error: Cannot find GTK: Is gtk-config in path? 

原因: 

解决:

sudo apt-get install libgtk1.2-dev

问题:eclipse中encoding不支持中文 

解决:编辑/var/lib/locales/supported.d/local,加一行zh_CN.GBK GBK,执行

sudo locale-gen

错误:gnome.h: No such file or directory 

错误: No package 'libpanelapplet-2.0' found 

原因: 

解决:

sudo apt-get install gnome-panel

问题:eva不弹出输入法 

解决:

sudo apt-get install scim-qtimm

问题:No package 'gtk+-2.0' found
No package 'gtksourceview-1.0' found
No package 'libgnomeui-2.0' found
No package 'libglade-2.0' found
No package 'libgnomeprintui-2.2' found 

解决:

sudo apt-get install libgtk2.0-dev libgtksourceview-dev libgnomeui-dev libglade2-dev libgnomeprint2.2-dev

问题:No package 'libpanelapplet-2.0' found 

解决:

sudo apt-get install libpanelappletmm-2.6-dev

编译安装 Pidgin 的步骤 

  1. 下载 Pidgin 的源代码包 pidgin-2.1.1.tar.bz2 (官方最新的版本)。
    wget http://jaist.dl.sourceforge.net/sourceforge/pidgin/pidgin-2.1.1.tar.bz2

  2. 安装编译 Pidgin 所需的依赖:
    sudo apt-get install libgtk2.0-dev libxml2-dev gettext libnss-dev libnspr-dev

  3. 解压源代码包
    tar jxvf pidgin-2.1.1.tar.bz2
    cd pidgin-2.1.1

  4. 编译
    ./configure (建议使用 –help 查询需要用到的参数)
    make
    sudo make install
    如果在 ./configure 这一步出现错误

    错误一:
    configure: error:
    You must have the GTK+ 2.0 development headers installed to compile Pidgin.
    If you only want to build Finch then specify –disable-gtkui when running configure.

    解决: `sudo apt-get install libgtk2.0-dev`

    错误二:
    configure: error:
    You must have libxml2 >= 2.6.0 development headers installed to build.

    解决:
    sudo apt-get install libxml2-dev

    错误三:
    configure: error:
    The msgfmt command is required to build libpurple. If it is installed on your system, ensure that it is in your path. If it is not, install GNU gettext to continue.

    解决:
    sudo apt-get install gettext

    如果在使用 GTalk 或 MSN 时出现错误

    错误:
    SSL Library/Libraries……… : None (MSN and Google Talk will not work
    without SSL!)

    解决:
    sudo apt-get install libnss-dev libnspr-dev

    Ubuntu编译时找不到Makefile的解决办法

  5. 如果是需要编译的环境,推荐安装"build  essential"包

    sudo  apt-get  install  build-essential

    再用./configure, make,  make install  ,方法安装软件是,经常会发生发生各种错误,而导致无法生成  makefile  文件。

转载请注明:微刻 blog.wecot.cn » Deepin/ Ubuntu中 ./configure 的一些常见错误

发表我的评论
取消评论
表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址